You can skip this in seconds

Click here to continue

Cyclonis Password Manager 1.0.4.38

What's Required in Version 1.0.4.38 of Cyclonis Password Manager

Windows 7 SP1 or newer. MacOS 10.11 or newer.

What's New in Version 1.0.4.38 of Cyclonis Password Manager

- Twenty-six languages added: Albanian, Chinese, Dutch, French, German, Japanese, Korean, Portuguese, Russian, Serbian, Spanish, etc
- Application settings redesign
- Improvements to item selection when using search feature
- Miscellaneous login from recognition fixes
- Fix for sync issues

Look for Similar Items by Category

Internet > Internet Tools
This product is also listed in: Password Managers

Feedback

Popular Downloads